List Archive

Thread

Thread Index

Message

From: "Lubomir I. Ivanov" <neolit123%gmail.com@localhost>
To: Peter Bohning <peter.bohning%gmx.com@localhost>, libzip mailing list <libzip-discuss%nih.at@localhost>
Subject: Re: mingw errors 1.3.0 1.4.0
Date: Wed, 3 Jan 2018 23:04:51 +0200

please, CC the mailing list in your replies.

On 3 January 2018 at 22:59, Peter Bohning <peter.bohning%gmx.com@localhost> 
wrote:
> well... if I had cmake, I wouldn't be torturing myself trying to compile it.
> that's the point, cmake won't compile, the cmake compile process crashes.
> So I'd like to use 1.3.0 source or a 1.4.0 that uses make files.

it's unclear what platform you are building on given your mingw
troubles. is that on native Windows or are you cross-building from
Linux?
in both cases you don't have to build cmake yourself - you can
download it pre-built. what prevents you from doing that?

>  why was libzip changed away from make?
>

cmake can give the occasional issues, but i'm sure that the libzip dev
team moved to cmake for a very simple reason - it one of the more
portable build systems.

lubomir
--

Made by MHonArc.